[Workaround] Stuck Characters

travisbaldreetravisbaldree Posts: 1,665 ✭✭✭✭
If you are stuck! There is a solution-

If you have a town portal, try opening it and going through if you can -
However, if that doesn't work, I have a handy console command we can enable for you. You can 'ascend' a floor ( which will NOT mark you as a cheater ), and that should get you out.

From start->run

%appdata%

and press enter

Then browse to runic games\torchlight
there should be a settings.txt file in there

change
Console :0

to

Console :1

Now, when you load your character, hold SHIFT and press the ~ key
a console should come up -
type ASCEND and press return
that should pop you up a level and hopefully you should be un-stuck.

EDIT: If you're on a Mac:

1) Browse to ~/Library/Application Support/runic games/torchlight (replace ~ with your username)
2) Open settings.txt
3) Change Console :0 to Console :1 and save
4) Launch Torchlight
5) While loading your character, hit shift+~
6) A console should appear. Type ASCEND and press return. This should resolve the issue.

Note: On either Mac and PC you may inadvertently enter a testing level if you hold down shift alone while loading your character. Other posters have mentioned receiving a green screen. This is most likely the cause. A simple shift+~ key command for a moment is all that is required to trigger the console.
«13456711

Comments

  • Man, I wish I had read this five minutes ago :P I was in a Secret Mine, wreaking my usual havoc, when all of a sudden I found myself transported up to a ledge (where a few enemies had spawned and jumped down moments before) with no chance of getting down. In this case the bug was actually welcome, as it gave me a good excuse to stop playing for the night, but it's still good to see that there is a workaround for getting stuck in the geometry should it happen again. But I guess the console has to be enabled upon game start for it to work, right?

    But I have a question regarding the ASCEND-command: what happens if I use it in a Secret Mine, or another area outside of the main dungeon? Will it simply transport me to the level from which I teleported into the area?

    Lastly, some information regarding the bug, should it be of interest: I suspect it might have happened when I unsuspectedly clicked on a weapon that had dropped up on the aforementioned ledge. In a way that could probably be the real bug, as I assume items dropping out of reach isn't really according to plan anyway? :)
    Torchlight version: Steam
    System: Intel Q9450, 4 GB RAM, Geforce 8800 GTX, NI Audio Kontrol 1, Windows XP SP3 w/all updates
  • im stuck, cant use a town portal scroll, and the console will not work even following ur instructions.

    first, settings.txt gets reset every time i open the game.
    second, setting it to read only still results in me not being able to bring up the console.
    third, i presumed this was due to american vs british keyboard layouts and the tilide key, on a british keyboard tilide is shift+# (i tried shift+¬ aswell)
    so,
    fourth, i changed

    KEYMAP_CONSOLEKEY_PRESS :192 (~)

    to

    KEYMAP_CONSOLEKEY_PRESS :76 (L)

    this change should mean i now have to press shift+L to get the console up.

    Still no console.

    still stuck.

    to note, vista 64 + steam

    http://i37.tinypic.com/e99kwh.jpg
    Help please!
  • ZekranZekran Posts: 2
    In my case, the settings.txt saves but pressing Shift+~ does not bring up anything resembling a console.

    Vista Business
    Steam


    I was having fun with that destroyer too.
  • some more stuff of interest:

    deleting the settings file and then running the game results in the game creating a new settings file with all default values. (ie back to square one)

    i then noted that leaving it writable, and proceeding to edit ANYTHING the values stick when running the game.

    however the 2nd i change CONSOLE :0 to 1

    and then run the game, that value gets changed back.

    nothing else gets reset though.

    Why?

    also http://www.xtarsia.net/torchlight/0.svt if someone would kindly, load that save game, teleport me up 1 level and upload the "fixed" save somewhere?

    Preferably would like to be able to get the console working though incase this happens again :(
  • ZekranZekran Posts: 2
    Same for me now that I dig into the settings.txt more. No other values will revert except the Console command.


    Running the game reverts it back to 0.
  • Same as all else, played the demo, was pleasantly surprised, purchased the game and got wellied in, an hour or so later approx got stuck.

    I can always restart as its only one or two hours on this character but this could just as easily turn into twenty hours in on the next one, as such I would rather get this resolved first.

    Changed "Console :0" to read "Console :1", made the file "Read Only" after seeing it refused to stay set on the first attempt.

    SHIFT+~
    SHIFT+¬
    SHIFT+`
    SHIFT+#

    And dozens of other random combination's which get further and further from the posted keys seem to have zero effect.

    Its been a very long time sine I have had to manually bind anything so I have no idea what the numbers represent anymore, only thing I can presume is 192=Tilde and 16=Shift (purely speculative from what's been stated combined with whats within the .txt file).

    Anyway............ :|

    ***EDIT***

    Sorry, neglected to say but...

    O/S: W7-64u

    Region and Language:

    Format: English (UK)
    Location: UK
    Keyboards and Languages: English (UK)

    *END*EDIT*
  • I've saved a version of your character with him in town, hope that helps:

    http://flamingbarrels.com/Ascended.svt

    Sorry the console isn't working, it may have something to do with the way it was disabled for the demo. Hopefully we can get that fixed up soon as well.
  • ooh, thank you very much!

    or actually... curse you! i was just about to go to sleep :lol:
  • Travis' instructions worked for me. Thanks!
    "Modder" =/= "Cheater"
    "Modder" > "Cheater"

    The difference between constructive criticism and whining is the ability to provide a realistic solution.

    Felicia Day plays Torchlight!
  • I tried everything described and I couldn't get the console window open. Is there a possibility of getting a /stuck style command or something into a patch? So that players don't have to access the console and run through an entire floor?
  • GeldorGeldor Posts: 20
    To me it was Shift + Ø (Norwegian keyboard).
  • Hi, Im stuck too, between a table and two boxes. I cant open the console in the described way, is there anything i can do but start from the beginning?
  • Stuck as well. Console setting gets reverted back to 0 when I run the game, and there's no way to get any console up.

    Basically game over.
  • GeneGene Posts: 98
    Here's a direct link to an image showing a location where you can get stuck; it's duplicatable at this location (just kinda mill about in the 'V' location where the boxes and table meet).

    Here's the link:
    http://img503.imageshack.us/img503/8851/stickpoint.jpg
  • stuck here also. hit a trap that pushed me over a set of rocks and cannot move, cannot use town portal and cannot access console

    http://imgur.com/nAL6k.jpg
  • apolloapollo Posts: 1
    I am also stuck. Tried the console fix with no luck. Can't use a town portal. Any help would be appreciated.

    http://dl.getdropbox.com/u/928377/photos/torchlight.jpg
  • I'm stuck as well. Only the third level in. Console doesn't work. This looks to be something you all at Runic might want to address rather quickly.
  • jamesLjamesL Posts: 3,568
    anybody want to email me their char and I'll use the console to ascend them
    then I can email the char file back to you
    I don't have a sig
  • iChiiChi Posts: 11
    thx alot!!! HUGE HELP!
    ichiu.jpg
  • DeityDeity Posts: 7
    Refreshing if not unusual to see such a responsive dev. team.

    Keep up the great works guys.
  • thank **** this worked i didnt want to start over again lol

    thanks :>
  • I'm stuck too, but this time I'm stuck in town! Specifically lower left-hand corner, behind the Miner. I tried using the console command but it doesnt work. I'm sad now :( Mayhaps I can send someone my save to unstuck me?

    Here's the photo:
    http://i33.tinypic.com/2yl04e0.jpg
  • i am also stuck in abandoned mines lvl 1 (portal quest). my lvl 7 destroyer with unique axe is stuck :(

    running from steam in bootcamp on a mac...console will not work
  • jamesLjamesL Posts: 3,568
    jamesL wrote:
    anybody want to email me their char and I'll use the console to ascend them
    then I can email the char file back to you
    I don't have a sig
  • ............



    Console is clearly not working for some people. Still stuck.
  • HuggsHuggs Posts: 61
    My console also resets to off...
  • my console doesn't work too
    o.s. vista home basic 32bit
    steam

    ps. how can I change difficulty?
  • managed to free myself - used the destroyer's dash skill and clicked the town portal i had opened (per OP suggestion) in the middle of the dash and got back to town

    yay!
  • ip99ip99 Posts: 1
    Hi

    I am stuck to. Was wondering if a patch is close?

    Would be nice with an unstuck button. A port into town perhaps. (with warning that you would not be able to return to the same place without refighting some content)
  • I restarted eventually but was curious, people seem to think this is going to be fixed in a patch but I haven't seen this mentioned anywhere, I don't think I've even read a yellow post acknowledging it so...

    If this happens 20, 30, 40 hours in its going to be a real pain in the ****.

    ***EDIT***

    Ah, correction, missed this as it was directly after my initial post.
    Volbard wrote:
    Sorry the console isn't working, it may have something to do with the way it was disabled for the demo. Hopefully we can get that fixed up soon as well.

    *END*EDIT*
«13456711
This discussion has been closed.