How to change resolution out of game?

RavenousTofuRavenousTofu Posts: 2
Accidently set my resolution in-game to one my computer doesn't support, and now everytime i load it up it just gives me a black screen
Anyway to change resolution out of the game?

Comments

  • BrianWBrianW Posts: 2,310 admin
    I'm assuming you're on a PC:

    In %appdata%\runic games\torchlight\settings.txt, change RES_WIDTH and RES_HEIGHT to the desired values, save, and launch the game.
    BrianW
    Community Manager // Mr. Nice Guy

    Join us on Discord! https://discord.gg/runicgames
  • I can't get the game to STOP changing my settings back to 1024x768 AA-Off.
    I've tried everything I can think of. Every file that has the word "settings" in it has had every instance of a resolution setting changed to the appropriate width and height for 1280x1024, the game lists it as a possibility to use this resolution. But every time I change the resolution, or click the checkbox for antialiasing (since its never checked) and the game opens back up, it's unchecked and the resolution is back to being 1024x768. I don't use 1024x768, not on any other games, or as the native resolution of the operating system. I've deactivated steam cloud sync, and have verified that the settings files are now STAYING @ 1280x1024 with the settings I want the game to have...are these fake buttons are what? I've been messing with this for two hours of what was my last day to play some games with my son and frustrated is an understatement. I'm giving up and maybe he'll wanna play someone elses game with me =/ he really likes T2 and I was excited to see him have interest in a game like this with actual statistics and more than one critical button to press. Games that "argue" with me like I don't know what I want my settings to be is just infuriating.

    EDIT: Now I've discovered that if I change the resolution in-game, and hit apply before checking the AntiAliasing checkbox, the resolution will correctly apply, but when I then click the checkbox for AA and hit apply, the game restarts like it should, to apply the settings, but then the resolution reverts to 1024x768 and AA is OFF, back to square one. I can't figure this out.
  • nVidia control panel has a global settings menu which SOMETIMES over-ride program settings. And then there are program specific sub-settings inside the nVidia control panel which over-ride the nVidia global settings, which over-ride the program settings...

    "Program settings, in the global settings, that over-ride the program settings INSIDE the program...."
    just shoot me...

    And it still doesn't want to stay enabled to either of the correct settings. I can enable resolution sometimes through various ways (none of which change anything if I want to use AA) I really just don't get this at all. I hope someone knows what the problem is for me. Specs shouldn't an issue, I've got DX and drivers updated and I regularly play much more frequently updated games than T2. This is such a strange problem.
Sign In or Register to comment.