[Bug] Pet's equipped items are vanishing.

HojichaHojicha Posts: 64
edited September 2016 in Torchlight II Support
I selected the collar reward from the first quest in the starting area and equipped it on my pet. A while later in the game, I got another item for my pet. When I opened my pet's inventory, it no longer had the collar on. I'm sure I selected the collar and put it on the pet, but I thought maybe I made a mistake and clicked it off somehow. I started getting equipment for the pet again. I had a collar and two tags on it, and had upgraded the items a couple times over the course of a few hours without a problem. I took a break, closed the game and came back to it a while later. When I opened my pet's inventory, all of its equipment was gone again. The items are definitely not anywhere in my inventory or stash.

I am playing the game through Steam in LAN mode. I did not leave the game the first time it happened, my game has not crashed, and I haven't lost any other progress or items. I bought some cheap pet gear from the vendor to try to reproduce the error, but unfortunately, I haven't had any luck and have no idea what conditions are causing this to happen sometimes.

Comments

  • I have the same problem with vanishing pet equipment.
    I had played a LAN-game, bought/got rewarded some great pet tags and had these equipped while i exited the game. When I joined the LAN-game again my pet tags where gone. They are not in any inventory or stash.
    I did have other pet tags in my (not my pet's) inventory to sell, but those where still in my inventory when i re-joined. My friend who was hosting still had his pet tags. It was a 2 player game.

    I spent quite some money on one of those tags and can imagine a lot of people losing valuable equipment this way. Hopefully it will be fixed.
    Until then if you have encountered the same problem: Store your pet equipment in your own inventory while you exit a LAN-game. This might help keeping your stuff safe :)

    (Sorry for the spelling errors, english is not my main language)
  • I will begin investigating this issue; thank you Blaise and Hojicha for reporting it.
    "In the beginning, the Universe was created. This made a lot of people angry, and has been widely regarded as a bad idea."

    The Guide
  • I have been unable to reproduce this issue so far. I have logged in and out of LAN games with every collar and tag under level 25, but the items are still present when I return. Are there any other details that you can remember? Do you recall what color the item was? Or the specific bonus the item gave?
    "In the beginning, the Universe was created. This made a lot of people angry, and has been widely regarded as a bad idea."

    The Guide
  • JZiegler wrote:
    I have been unable to reproduce this issue so far. I have logged in and out of LAN games with every collar and tag under level 25, but the items are still present when I return. Are there any other details that you can remember? Do you recall what color the item was? Or the specific bonus the item gave?
    I haven't been able to reproduce the issue either. Whatever caused it doesn't seem consistent or frequent. Those are the worst kind of bugs to fix. :/

    The first item that disappeared was from the quest reward on the way to Estherian Enclave. I don't know if the stats on that are always the same. I chose that reward on another character and didn't have any problems with it. The second time it happened, all three of my items disappeared at once (two tags and a collar). I think they were all green level items, or one might have been blue. I do remember that all three of these items had the stat "Health steal to Master on Hit" or "Health on Hit". I think they had some other stats but I don't remember what they were. I got a new tag with this stat on it and it has not disappeared yet, but I haven't had much time to play today.

    The disappearing items all happened while playing the Engineer class. I'm using the cat as a pet. I'm playing on veteran difficulty. Like the other person who reported this, I was in a LAN game when it happened, but unlike the other person I was the host. Of course, LAN could just be coincidental. The other person playing with me has not had this issue and was using an Embermage with a cat as a pet. If there are any other details that might be helpful please let me know.

    Now that I know it has a chance to happen I'll check my pet's items more frequently and report back with more details if it happens again.
  • Thank you for looking into it :)

    One of the items was a (i think, this is the name I found on a similar item)"beast stub"tag. Bonuses where: 12 physical armor + 9 physical damage. I'm not sure what the other tag was but I got that one as a reward from one of the earliyer quests. My pet was not wearing a colar.
    I was playing the outlander class, with a pet ferret on normal difficulty. I'm not sure what level I was, but pretty sure it was somewhere 7-12. My friend was also playing outlander and had a pet panther, with verry diferent items equipped on it.
    Had not tought my pet any scroll spells, did send it to town once already, had not used any health or mana potions on it, it also never transformed using a fish.

    Unfortunatly it seems that there are a lot of differences between my game and the other poster. This might be a difficult one to pinpoint.

    If there are any other bits of info i can help with please let me know, I can't think of anything else that might be useful right now. I will try to reproduce this later on to see if i can make it happen again.
    Again sorry for the spelling and thank you a lot for looking into this!
  • I have also had this problem. I started playing in LAN with my friend, and after choosing the collar with "hit heals master" and playing for some time, all my pet's items were gone (both equipped and in its inventory). I didn't quit the LAN game when this happened, so I don't think the bug occurs when you quit the game. I am trying to reproduce the bug, but nothing happened again so far. One thing I should mention though is that my pet had died before I noticed the item loss, so i thought it was a game mechanics.
  • Hi,

    I have also experienced this problem: I played an internet session with a couple friends from level 1-19, on elite, all in one go. Over that time, I collected a few pet tags, etc: When I opened the same character in single player this morning, I found my pet was dying a lot, and assumed it was just sort of getting behind in gear... when I found a pet tag and noticed there was no compare item, I checked, and found that it had no items. I had a white collar, and two rare pet tags: Both pet tags gave ice armor, but that is the only common stat I can think of (purely from memory: one tag was 9 hp on hit to master, 20 ish ice armor, and something I forget, the other was 30 or so ice armor, +32 physical damage, and I think +2 all armor (as all but ice was listed, I assume ice is rolled into one display)). Details if it helps: Steam game, level 19 when I logged out (embermage), level 20 by the time I noticed, panda as a pet. Sadly I cannot think of anything else with possible relevance. I work in QA, I know this is the worst kind of bug to hear about. If you have any telemetry, it was an online game, with the same username as my forum name.
  • velaraxvelarax Posts: 17
    I have this problem in SPmode and it's getting darned annoying. TL2 crashes a lot since the most recent patch. Every single pet item I have selected and equipped has disappeared from my inventory.
  • CalinjarCalinjar Posts: 1
    Bump, this is still an issue. Not sure if the game still gets supported but here's my case:

    I played my character all the while to lvl ~55 on internet games with Normal or Veteran difficulty. Then I switched once into Single Player mode which is locked to Elite (since I chose that at character creation). Now logging again into internet games, my pet's items vanished. Nothing valuable but still annoying. Thanks in advance.

    Calinjar
  • crazylandcrazyland Posts: 1
    Same here, I'm lvl 50+ now and suddenly all pet's equipment is gone. Managed to replace it in a while but then noticed something worse - all spells are marked in red and are not working. So I took 1 new spell, clicked to remove 1 old and suddenly the new spell also disappeared along with the old one. But now actually the pet does summons skeleton archers (the new spell that disappeared), so the new spell seems to be working although the 4th slot appears as empty. No idea what's going on. Here is a screenshot from my pet's spells: http://tinypic.com/r/2mquecp/8 This was in LAN, however, the issue stays in SP mode.
  • PhanjamPhanjam Posts: 3,281 ✭✭✭
    hi crazyland. that looks like a mod pet. did that mod have an update recently or something like that?
    Lvw5p3z.png
    Torchlight 1 Class Pack (TL1CP) Mod for TL2: Steam | RGF
  • D2HansD2Hans Posts: 3,024 ✭✭
    Phanjam wrote:
    hi crazyland. that looks like a mod pet. did that mod have an update recently or something like that?

    To add to that are you using any other mods as well. Maybe a mod conflict
    "Six... one, six... the nuuuumber ooof the beeeaaast!"
  • Google search brought me here. Just happened to me. Was playing a mulitplayer game with a friend who had to leave. So this was about 30 minutes after equipping a collar. Once I was on single player I began fishing and when transferring fish into my pets inventory, that's when I noticed his collar was gone.
Sign In or Register to comment.