Torchlight 2 simply won't launch.

JohnCourageJohnCourage Posts: 7
edited October 2012 in Torchlight II Support
I've installed Torchlight 2, but the game itself will not launch; if I use the launcher and click on 'Play', the launcher closes but nothing happens. If I try using the torchlight2.exe, again, nothing happens. I've tried downloading and installing both from the normal downloader and from the offline downloader, but both have the same result.

My system meets the requirements for the game, all available windows updates have been applied, and I have updated the graphics and audio drivers today.

Any suggestions?
«13

Comments

  • BoratolBoratol Posts: 22
    edited September 2012
    ... Exactly the same for me here! I'm sure we're not alone!

    @ JohnCourage: Do you have all the C++ Libraries installed ie.: 2008 redist. + 2008 redist. (SP1) + 2010 redist. etc. ?
    Just wondering, have you tried uninstalling them, rebooting and reinstalling?

    For my part, the only thing I haven't tried so far is uninstalling _all_ the C++ libraries ... IDK if that would help.

    BTW ...
    @ BrianW (Hopefully Brian or another Dev. will read this): additional infos ...

    => This path doesn't even exist on my computer! { My Documents\My Games\Runic Games\Torchlight 2 } // From Post: viewtopic.php?f=54&t=34478
    => Ogre.log nowhere to be found in C: drive
    => There is no application Error in the windows "Event viewer"

    *edit: updated system specs
    System Info:
    OS: win XP 32 (SP3) - Fully updated/patched
    CPU: Intel Core 2 Quad @ 2.66Ghz (Q9450)
    RAM: 8 Gb (3.25GB 32bits OS)
    DirectX: 9.0c (June 2010) -dxdiag passed every tests successfully
    Video: nVidia GF - GTS450 1Gb RAM


    I'm ready to try a lot of thing to make this game works but unfortunately I'm not ready to Axe and whack everything in this windows install 'cause I do a lot more than just play games with this computer of mine! I need it for work ... :'(

    Help anyone, please!!!
    Asus P5Q Pro Turbo * Intel Q9450 Quad Core 2.66Mhz * 8Gb RAM * nVidia GTS-450 1Gb * XP32 SP3 * DirectX 9.0c (June 2010 update)
  • What are the software requirement aside the C++ 2010 library? ... do we need 2010 SP1 to be installed?
    Do we need .NET thingy to be installed?

    This must be pretty easy to nail down for someone who know a little about these things ('cause I don't)...

    No hint at all!? ... anything? anyone?
    Asus P5Q Pro Turbo * Intel Q9450 Quad Core 2.66Mhz * 8Gb RAM * nVidia GTS-450 1Gb * XP32 SP3 * DirectX 9.0c (June 2010 update)
  • Boratol wrote:
    ... Exactly the same for me here! I'm sure we're not alone!

    But it surely does feel like it right now! :shock:
    Asus P5Q Pro Turbo * Intel Q9450 Quad Core 2.66Mhz * 8Gb RAM * nVidia GTS-450 1Gb * XP32 SP3 * DirectX 9.0c (June 2010 update)
  • Can you guys look in your documents under my games. In there you should see a folder called runic and then in there you should see Torchlight 2 folder.

    Inside the torchlight 2 folder is file named ogre.log. Do you think you could just paste the contents into a reply here?

    my games/runic games/torchlight2/ogre.log

    Thanks! Hopefully we can get this fixed for you.
  • Quite a few of you report not having that folder..which is weird.

    What you can try is go to your steam folder(or whatever folder the non steam version is installed to), open the games folder and install DirectX and the other thing.
    You can also try verifying file integrity.
  • @Marsh: Tkx a bunch for the reply!

    Just to make double sure, do you mean in C:\Documents and Settings\%user%\My Documents\My Games ?

    If yes then like I stated in my previous post, I don't even have a folder named runic in My Games ...

    Is it possible that this folder is created at game first start? That would explain why! :cry:
    Asus P5Q Pro Turbo * Intel Q9450 Quad Core 2.66Mhz * 8Gb RAM * nVidia GTS-450 1Gb * XP32 SP3 * DirectX 9.0c (June 2010 update)
  • @KirasiN91: thanks for your answer ... I'm not on Steam - It's a standalone install there is no directX installable in the game folder?!? :o

    I did reinstalled (refresh) directX 9c (june 2010) but still no joy!

    And I did Un-install the game and reinstall (with reboot in between) with the PW exec (first try), with Runic "Torchlight2_FullInstall.exe" (second try), and lastly with "Torchlight2_StubInstall.exe" no go, all exactly the same
    Asus P5Q Pro Turbo * Intel Q9450 Quad Core 2.66Mhz * 8Gb RAM * nVidia GTS-450 1Gb * XP32 SP3 * DirectX 9.0c (June 2010 update)
  • sorry that I missed that. So our guess over here is that there is some kind of weird permission thing going on. Not sure how you have your system setup but maybe you can try just creating the directories manually. My fear is that even then windows might not give the game permission to write to it. But it might be worth a try if your down.

    Here are the directories you need:
    My Games\runic games\torchlight 2\
    My Games\runic games\torchlight 2\save
    My Games\runic games\torchlight 2\logs

    hoping this fixes you.
  • How about running the installed with administrative rights? That should allow folder creation.
  • @marsh: I did create manually all the the folder you listed ... no changes

    I'm the only user on this computer XP32 and I am the Administrator. BTW I do have other games listed in this "My Games" (12 to be exact) folder but "Torchlight 2" never created those I did manually, on any of the install run!

    As for permission I really don't have anything special defined in there, as far as I know ... Any other clues? ...

    @KirasiN91: It's an old XP32 I don't see anyway (I don't think there is a way) of running the exec with Admin rights those were introduced in Vista I think 8-)
    Asus P5Q Pro Turbo * Intel Q9450 Quad Core 2.66Mhz * 8Gb RAM * nVidia GTS-450 1Gb * XP32 SP3 * DirectX 9.0c (June 2010 update)
  • jamesLjamesL Posts: 3,568
    I have no idea if this will help

    you should have a folder named
    \Documents\My Games\Runic Games\Torchlight 2\
    or if you're on XP
    \My Documents\My Games\Runic Games\Torchlight 2\

    download these 3 files and put them in the that folder

    local_settings.txt
    http://www.filedropper.com/localsettings

    resourceconfig.dat
    http://www.filedropper.com/resourceconfig

    settings.txt
    http://www.filedropper.com/settings
    I don't have a sig
  • OK, I had this problem as well, here is what I found.
    System: Asus G73, Win 7
    Installed game, didn't run
    Found kernalbase fault in event log for Torchlight2.exe
    Could not find Torchlight2.exe anywhere
    Uninstalled, rebooted, reinstalled with Custom
    Found that it installs in the C:\Users\Public\Games folder by default
    The exe is now present but still get kernalbase faults
    Copied the Torchlight2 folder into C:\Users\MYNAME\runic games
    It now runs, go figure

    So, for Win 7 users, check to see where it installed. If this works for you and you don't reinstall don't forget to change your shortcut for the launcher.

    Not sure about Win XP, might be something similar.

    Good luck!
  • LeakLeak Posts: 107
    You might want to grab Process Monitor from Sysinternals (now part of Microsoft), run it and try launching the game. After it's done, hit Control+E to stop the capture, hit Control+F and type "torchlight2.exe" in the find dialog to find the first line mentioning Torchlight2.exe in the "Process Name" column then right click the word "Torchlight2.exe" in the list and choose "Include 'Torchlight2.exe'".

    That'll filter the list to everything TL2 did, and if you start looking from the bottom you might find something that made the game exit quietly...
  • Thanks for the various suggestions - I definitely appreciate the effort and the response, even if things haven't worked out yet.
    Some replies to the various suggestions:

    Those folders didn't exist for me initially.
    I tried creating them, that didn't change things.
    I tried adding those three linked files to the main created folder, no luck there.

    In general I run my XP SP3 32bit install as administrator, so I wouldn't have expected any permissions problems (but then, it's odd that those folders weren't created initially).

    Poking around with Process Explorer as someone suggested, the following entries were the last few. I hit the .exe (manually, rather than via the launcher) at 01:10:18, and the last relevant entry was 6 seconds later ~01:10:24.
    The entries are below; let me know if others would be more useful, or if you'd like all relevant ones (although that'd probably fit better in a file attachment, rather than pasted into the forums)

    01:10:24.3402562 Torchlight2.exe 3676 Process Exit SUCCESS Exit Status: -1, User Time: 0.2343750 seconds, Kernel Time: 0.4375000 seconds, Private Bytes: 144,560,128, Peak Private Bytes: 146,481,152, Working Set: 30,642,176, Peak Working Set: 30,998,528

    01:10:24.3402892 Torchlight2.exe 3676 CloseFile C:\Program Files\Runic Games\Torchlight 2 SUCCESS

    01:10:24.3404334 Torchlight2.exe 3676 CloseFile C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.6028_x-ww_61e65202 SUCCESS

    01:10:24.3404697 Torchlight2.exe 3676 CloseFile C:\Program Files\Runic Games\Torchlight 2\Torchlight2.exe SUCCESS
  • LeakLeak Posts: 107
    Poking around with Process Explorer as someone suggested, the following entries were the last few. I hit the .exe (manually, rather than via the launcher) at 01:10:18, and the last relevant entry was 6 seconds later ~01:10:24.
    The entries are below; let me know if others would be more useful, or if you'd like all relevant ones (although that'd probably fit better in a file attachment, rather than pasted into the forums)
    That excerpt you posted only show the process exiting; the exciting stuff what goes horribly wrong must have been above that...
  • Starting to think this is an issue with our DRM. We are going to try a few things and I'll be getting back to everybody hopefully soon.
  • I Just tried installing the game on another computer completely different rigs ... the exact same thing happen:

    - No folder creation in My documents/My Games/ (no Runic Games subs) at game installation time.
    - Hitting the "play" button in the tl2 launch manager with the windows task manager opened, I can see Torchelight2.exe closes, almost as soon as it start and that's it no error message at all and no log file created
    Asus P5Q Pro Turbo * Intel Q9450 Quad Core 2.66Mhz * 8Gb RAM * nVidia GTS-450 1Gb * XP32 SP3 * DirectX 9.0c (June 2010 update)
  • Has this issue been resolved yet?
    I've had the same problem since purchasing the game yesterday.
  • Vandalise wrote:
    OK, I had this problem as well, here is what I found.
    System: Asus G73, Win 7
    Installed game, didn't run
    Found kernalbase fault in event log for Torchlight2.exe
    Could not find Torchlight2.exe anywhere
    Uninstalled, rebooted, reinstalled with Custom
    Found that it installs in the C:\Users\Public\Games folder by default
    The exe is now present but still get kernalbase faults
    Copied the Torchlight2 folder into C:\Users\MYNAME\runic games
    It now runs, go figure

    So, for Win 7 users, check to see where it installed. If this works for you and you don't reinstall don't forget to change your shortcut for the launcher.

    Not sure about Win XP, might be something similar.

    Good luck!

    This worked for me. Copy and pasted from the Users\Public\Games folder to the Users\[me]\ folder and it's launched from the new location.
  • BugitBugit Posts: 21
    i generally install games into program files; always works and it currently works on my windows7 desktop. does not work on my windowsXP laptop however. i have tried all of the above to no avail. (want to be able to tote the beastly game around and play)
    Bugging people since that-one-time-with-that-wack-stuff-that-was-like-totally-crazy-and-stuff.
    yeah, that ^
  • I have the same problem here, no response after I click play.
  • Cant launch the game either was able to yesterday but now nothing happens when I try launching from either the exe or launcher. Tried installing to different location also moving to username location and still nothing. Got to play the game for 1 hr yesterday and at 20.00 thought it was a great deal but not so much anymore if I cant play it again because its broken.
    Wonder if any of the devs are aware of this problem anyone find any new fixs to this issue?

    Seems odd that one day its working and havent changed anything in the computer and the next day after a patch it is no longer working?
  • Marsh wrote:
    Starting to think this is an issue with our DRM. We are going to try a few things and I'll be getting back to everybody hopefully soon.

    Don't mean to bug you guys but, anything new about this issue? ... I'm wondering if this thread is being forgotten under the rubble :)
    I really am looking forward to be playing this game :cry:

    In the mean time I would like to add two (2) other computers to the list, on witch the games won't install properly nor run, both are:

    XP32 (SP3)
    P4 Duo Core 2
    nVidia Video one with GTS-550 (1Gb GDDR5)
    RAM 2Gb
    Asus Main Boards
    Latest drivers + windows update
    Asus P5Q Pro Turbo * Intel Q9450 Quad Core 2.66Mhz * 8Gb RAM * nVidia GTS-450 1Gb * XP32 SP3 * DirectX 9.0c (June 2010 update)
  • As above, it'd be great to know if there's been any progress with this one. I got a heroic effort to deploy an attempted fix from Marsh, but that didn't work out in the end.

    Then, from looking at it, there's something like three people in total with this issue... Odd.
  • I got a heroic effort to deploy an attempted fix from Marsh, but that didn't work out in the end.
    @JohnCourage: Would you mind letting me know what you did try? ... I would like to give it go too ... if it's not confidential of course :)

    And I doubt it a lot that there is only 3 people with this I already know 4 who have this problem, aside of me and you :P
    Asus P5Q Pro Turbo * Intel Q9450 Quad Core 2.66Mhz * 8Gb RAM * nVidia GTS-450 1Gb * XP32 SP3 * DirectX 9.0c (June 2010 update)
  • BugitBugit Posts: 21
    in search of resolution to problem.
    Bugging people since that-one-time-with-that-wack-stuff-that-was-like-totally-crazy-and-stuff.
    yeah, that ^
  • I believe I am having the same issue, although it may just be a similar one as some details were not present in other's recountings. I have tried 3 times (unsuccessfully) to download and install the game.

    XP32 SP3
    Intel Dual Core 6600 @2.4
    3GB RAM

    Each time, it has downloaded fine, then it downloads a patch. When it goes to apply the patch, the launcher freezes with about 100MB left. I can close the launcher, re-open it, and it will complete everything and give me the option to play. I click play, and it definitely is trying to start something... 5-8 seconds later It pops up with "Torchlight2.exe has encountered a problem and needs to close." I can click there to see the data in the error report:
    AppName: torchlight2.exe AppVer: 1.11.2.3 ModName: kernel32.dll
    ModVer: 5.1.2600.5781 Offset: 00012afb

    Would really like to play the game, been almost a week since Marsh said he was looking into it. Any follow up or help would be appreciated.
  • Exact same problem. Download the stub installer, install this fine. Try and then launch Torchlight2. The Tl2.lancher process starts and then just stops. Getting the following in the event log;

    Fault bucket , type 0
    Event Name: PCA2
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: tl2.runic.launcher.exe
    P2: 3.2.1.35
    P3: Torchlight II
    P4: Torchlight II
    P5: Solid State Networks
    P6: 200
    P7: -1
    P8:
    P9:
    P10:

    Attached files:
    C:\Users\<username>\AppData\Local\Temp\{6f83c4ea-4066-427c-b9a2-c95b9c60e129}\appcompat.txt
    C:\Users\<username>\AppData\Local\Temp\Tab4CD9.tmp

    These files may be available here:


    Analysis symbol:
    Rechecking for solution: 0
    Report Id: ebe122da-0950-11e2-8f50-cc52af83f2da
    Report Status: 0
  • Anyone is still looking for a fix about this bug?

    For what it's worth, maybe this can help the devs nail that problem down, ('cause they might not have access to a computer with XP installed on it) :shock:

    I was so bored of waiting last night, that I tried installing the game on Linux via Wine 1.4. It did work the same as on XP, it failed in the exact same way at install time, it did not create the Runic Games subfolder in My Document ie.: Runic Games/Torchlight 2/ (and the 3 subfolders that it should contains - logs, save and screenshots) that and a bunch of registry entries were missing too! :oops:

    I hope you guys find a fix, I've chew so much on my keyboard the past week that I soon won't have any keyboard left! lol
    Asus P5Q Pro Turbo * Intel Q9450 Quad Core 2.66Mhz * 8Gb RAM * nVidia GTS-450 1Gb * XP32 SP3 * DirectX 9.0c (June 2010 update)
  • FaceFace Posts: 22
    XP SP3 admin user account with Runic TL2 version. Im having a similiar problem where if the game has crashed for whatever reason while it is running, somehow it would produce the same "silent startup crash" every time i try to restart it. I tried many different ways to fix the problem(rebooting, removing game save data and settings, removing tl2launcher cache etc.) but in the end i had to resort to reinstalling to fix the problem and nothing would work. I think i found a possible solution or at least the steps i took to finally make the game run again and create the required "*\My Documents\My Games\Torchlight 2" directories. The steps i produced to make it work:

    1. run installer, accept license
    2. select custom, click next
    3. select install just for me, click next
    4. destination folder -> click browse... -> C:\Games\Runic Games\Torchlight 2\ (from my last previous install)
    I manually clicked on the last folder in the browse window(Torchlight 2) then click ok
    4. allow creation of shortcuts, click install
    5. wait until install is finish
    6. uncheck run Torchlight 2 and exit installer

    Afterwards the folders were finally created and instead of running tl2launcher, i directly executed Torchlight2.exe and it worked.
    Patched and restored my backup saves and settings without any further issues so far. I think there is a bug in the launcher
    and drm registry when selecting where to install or reading the correct game data directories?. I can't 100% confirm this
    works but thats how i got my version working again. Now to explain why the game refuses to run after a hard crash i have no clue on that.
«13
This discussion has been closed.