Level 1 Embermage in multiplayer.

13»

Comments

  • Any news on this? I only just started playing TL2, after starting a coop session with some friends they told me that Embermage was bugged, so I avoided it and researched it only to find this thread and that the issue persists. I was having a lot of fun playing through with Engineer and had planned on playing through coop with each class, but it seems as though I'm going to have to put this game off for a while until I can get the full experience in coop. I'll subscribe to this thread in case the issue is every resolved.
  • I have to bump this post, because its still not fixed in patch 1.25.5.2 .. Im playing as Outlander, and my friend an Embermage. He kept dying, and his name was changed to Embermage, and inspecting, it showed as Level 1. Only in Act 2 right now, but its annoying. I recommended Torchlight 2 to him, he bought it on steam, and cant play with this bug.
  • BrianWBrianW Posts: 2,310 admin
    This is a known issue, but unfortunately we've never been able to track down the cause, and therefore don't have a known resolution at this time. If you'd like to submit your character save so we can take a look, please contact us at [email protected].
    BrianW
    Community Manager // Mr. Nice Guy

    Join us on Discord! https://discord.gg/runicgames
  • Falcon BUMP!

    Still happening. What can we do to help get this resolved? Want more character files? Observing it still in unmodded Internet games. Playing with two fellow embermages; they both lose their name and drop to level 1 in the UI. Then they die lots to weak creatures.
  • climax82climax82 Posts: 1
    edited December 2018

    Bump.

    Just bought this game and started playing it. Was playing single player Female Engineer. Heard there was a mod and started using the mod. Community Mod and Synergy. This made the game more fun with hordes of monster and new classes and abilities.

    Once I got to around level 23. I forgot which map area (at work). But it seems like there is one monster in every horde that can one hit kill me. Died by 1 wolf attack, died by one spider attack, died by 1 skeleton arrow attack, died by one boss spider (or elite). I did notice I can kill them from a distance before they can get to me but being a dragon princess with dual welding was more fun. But anyways I'm still seeing this bug. I tried removing all gears, save, and relaunch hoping it's one of the gears that was giving me the bug... because I was playing for 2-3 hours with no problems. Once I starting using new items and got to a new area I was dying left and right. This was frustrating because I was losing a lot of gold reviving. I don't know what else to do. So I went back to my non-modded character and it seems fine... for now. But I would like to get back to my modded character.

13»
Sign In or Register to comment.