[Patch 2] WARDROBE files - Out of Memory Error

TrenchcoatJesusTrenchcoatJesus Posts: 18
edited October 2012 in General Modding
Since the patch I have been getting an "Out of Memory" error when I try to start torchlight 2 with PAKs in my pak folder (besides the original). Sure enough, if I remove them it works just fine, but it appears when it tries to load any other PAK (that I've tried so far) it will give me an out of memory error and close.

I've also tried patching the original DATA.PAK with my modded files, but while this gets the game to load, it freezes and then crashes my computer seconds after I get to the main game menu.

Any ideas?

I've tried weeding out possible mod culprits but haven't found one just yet, including removing any mods that modify any skills changed in the last patch. I've also tried modifying the DATA.PAK date and repacking my other mod PAK files, none of which seems to help.


  • As an update, I think I've isolated the problem to modified WARDROBE files. I'm unpacking the new DATA.PAK now to see if there are some changes there, though I also felt mentioning a new bug that's popped up which is.. all of my pre-patch save files aren't loading when I do load the game.

    I made a new file just to make sure it was using the same directory, and indeed it showed up alongside all my old files, but I don't see ANY of my old characters in game. That's uh.. bad.

    EDIT: Restoring all old save files using the .restore file worked, and I am guessing that the save corruption occurred when I loaded the modified DATA.PAK, the game loaded and then crashed. So, be wary about using any mod which plays in the WARDROBE folder.
  • Okay, I've discovered that (presumably because of the fix to the missing engineer textures) when you are using mods which deal with replacing WARDROBE files, EACH individual file should be dated after the DATA.PAK in your paks folder.

    Just the PAK's date is not enough to make these work, and trying to work around it can result in bad stuff (like save corruption).

    This is kind of a major pain for me, but at least everything works now.
Sign In or Register to comment.