Corrupted Savegames?

I've got about 60 hours in Torchlight and have enjoyed it immensely even though the main quest was sorta short in that I finished it at roughly the ten hour mark still I have found things to do mainly in the vault that keeps my interest.

After 60 hours as you can imagine I am very attached to my character. Torchlight has been so stable for me only crashing three or four times in all of my play, and each of those other crashes requiring nothing more than merely restarting the game and all was well I was a little shocked to find the latest crash has seemingly corrupted my save games file.

When I try to load Torchlight now I get to the splash screen and find a cursor filled with sand that never goes anywhere. Out of curiosity I uninstalled and reinstalled the game and everything works fine, but when I copy over my old saves directory the same thing happens the program gets stuck at the splash screen and never goes any further.

If I delete the 0.SVT file the game loads fine but without my character, the only mods I loaded where the Total Respec mod but I haven't used any of the potions except one single time and that was maybe at the 15 hour mark. At this point I am wondering if there is any way to fix my seemingly corrupted save games?

I also tried renaming my backup.temp file to 0.SVT and still the same thing happen, one other thing I found odd here was the two files are NOT the same size, they are close but not the same I don't know if that is significant or not. I also don't understand how both the main save and the backup save could become corrupted at the exact same time?

All my other games and apps are still running normally and I even checked my SSD using the Intel SSD Toolbox to see if something was wrong with my SSD but all seems fine as mirrors my own experience using the PC.

I am not interested at this point at just starting again from scratch so if I can't get this fixed as much as I have enjoyed this game I think it will be time to move on to the next one. Any help here would be appreciated. I can link my 0.SVT file as well if that will help any.

Comments

  • BrianWBrianW Posts: 2,310 admin
    Try re-installing Torchlight and make sure that all mods are removed. Make sure to backup your game save before you do this. Once re-installed, see if you can get the save to load up under a fresh, working copy of the game. That might fix the save; however, it's not guaranteed to work. Good luck!
    BrianW
    Community Manager // Mr. Nice Guy

    Join us on Discord! https://discord.gg/runicgames
  • Thanks for the response this seems to have worked! Out of curiosity I then started to move the rest of the other files over one at a time to see if I could isolate which exact file was causing the problem, well the next file I moved over was the shared stash, after doing that the game once again would not start. Once I removed the shared stash file the game loaded and ran normally.

    I did have a bunch of stuff in the shared stash because I am a packrat and liked to collect different items in game but this is not a deal breaker. Again thanks for taking the time to answer my question. In the future I guess I will back up my save file directory every few days so this doesn't happen again.
Sign In or Register to comment.