Gothic Mephisto: [Font]

VendettaVendetta Posts: 156
edited August 2010 in Mod Showcase
I'd like to give thanks to Azrael for teaching me how to change game fonts.
Also, to the topics that took off the item borders ( I stole the file :P )


NONE OF THESE PICS ARE FULL SCREEN, THIS FONT IS SMALL TO MEDIUM SIZE.


Fiolex Mephisto Font:


-I've not only changed the game font to this, but also removed the borders. The only issue I'm having currently is the damage font on mobs being slightly smaller than expected. I believe this detail is made up for by the font looking phenomenal in every other respect.
-I realize this font is not Endor as noted in the files, all I've done is pasted another font type and renamed it Endor.

Instructions:
Just extract it and place it in the Mod Folder.
The download is listed here. [you will have to scroll down for download @ FileFactory]

Download

Tip: If you want to change the font to your own font, just go to this file path and rename whichever font download you want to "ENDOR.tff"
C:\Documents and Settings\Admin\Application Data\runic games\torchlight\mods\EndorFont\media\UI
*your user name may not be Admin, so change accordingly

________________________________________________________________________________________________

Here are some images I've compiled:

vfont1.png

vfont4.png

vfont2.png

Comments

  • This is actually kinda cool. Any way to make it slightly smaller? Right now it seems huge compared to default.
  • i really like this font, thanks for this.
  • VendettaVendetta Posts: 156
    I believe the pics just make it look large since I didn't give you a full screen shot.
    It's actually smaller than the original game font. But, to make the font smaller you would

    go into the path:
    C:\Documents and Settings\Admin\Application Data\runic games\torchlight\mods\EndorFont\media\UI

    inside to the individual font folder codes (there are 7), such as this
    <?xml version="1.0" ?>
    <Font Name="FrizQuadrata" Filename="media/ui/ENDOR.ttf" Type="FreeType" Size="11" NativeHorzRes="1024" NativeVertRes="768" AutoScaled="true" AntiAlias="true" />

    See where it says autoscaled=true? change that to false on the font you choose, feel free to play around with the size of the fonts too.
    I'm sure the large size fonts in that folder will be 12+ and you can change them to how you see fit. :D
  • That looks great . Well done .

    Think I'll ask to get it added to Torchleech , using all my mods through that now :)

    Edit: It's already been added to TL , that was quick :P
  • VendettaVendetta Posts: 156
    I'm glad you like it.
  • How hard is it to change the size of the fount I find that the font is too large except when it has to fit heaps of things in 1 box, which isnt very often, yet I really like the font.
    camo_sig2.png
  • VendettaVendetta Posts: 156
    Vendetta wrote:
    I believe the pics just make it look large since I didn't give you a full screen shot.
    It's actually smaller than the original game font. But, to make the font smaller you would

    go into the path:
    C:\Documents and Settings\Admin\Application Data\runic games\torchlight\mods\EndorFont\media\UI

    inside to the individual font folder codes (there are 7), such as this
    <?xml version="1.0" ?>
    <Font Name="FrizQuadrata" Filename="media/ui/ENDOR.ttf" Type="FreeType" Size="11" NativeHorzRes="1024" NativeVertRes="768" AutoScaled="true" AntiAlias="true" />

    See where it says autoscaled=true? change that to false on the font you choose, feel free to play around with the size of the fonts too.
    I'm sure the large size fonts in that folder will be 12+ and you can change them to how you see fit. :D

    ^ that post right here.
  • Thanks for that.

    Edit: Do I have to turn autoscale off with all of the files or just the main one?

    Just the main doesn't seem to work.

    Main one being " C:\Documents and Settings\Aaron.WOLLYS\Application Data\runic games\torchlight\mods\EndorFont\media\UI\FrizQuadrata"
    camo_sig2.png
  • Corpsie wrote:
    Thanks for that.

    Edit: Do I have to turn autoscale off with all of the files or just the main one?

    Just the main doesn't seem to work.

    Main one being " C:\Documents and Settings\Aaron.WOLLYS\Application Data\runic games\torchlight\mods\EndorFont\media\UI\FrizQuadrata"

    I can't even seem to edit these files in order to reduce the font size a wee bit. Can anyone help?

    *Edit - found it!*
  • hawknhawkn Posts: 8,348
    I liked the original TL font but this is pretty cool. much better than the diablo font.
    ...I most certainly am not the meanest person on these forums, I defer that position to hawkn. ~ AMB2010
    I7OBI.png
    Runic Games Fansite My Deviant
  • hawknhawkn Posts: 8,348
    The font doesn't show up well against the background.
    ...I most certainly am not the meanest person on these forums, I defer that position to hawkn. ~ AMB2010
    I7OBI.png
    Runic Games Fansite My Deviant
  • For some reason the font isnt appearing InGame, still has the Runic font....not sure what i did wrong lol....but havnt been able to get it to work yet :cry:
    1213498071323.gif
  • RarijRarij Posts: 1
    Same problem here, isn't working for me. Even after installing the mod the original game fonts are used, any fix for this? The font looks alot more awesome than the standard ones ;)
  • Umm I'm kinda new but is this for mac?
    And if it is how do I change it?
    Respond please!
Sign In or Register to comment.