"Torchlight 2 has stopped working", driving me crazy

tallrevkevtallrevkev Posts: 2
So I downloaded Torchlight 2 again on my new computer, (Windows 10) because I wanted to play it. Then that error message pops up at the thumbnail loading screen. Every. Single. Time. I've tried it in administrator, deleted the Runic Games folder (which is in my My Documents instead of AppData, funnily enough), verified the game cache, turned off cloud sync, redownloaded the game two times, to no avail. I think it must be something to do with DirectX because my Ogre.log ends with "D3D9 : Direct3D9 Rendering Subsystem created". Are there any other fixes that might end the pain? Does TL2 just not work with Windows 10?

Comments

  • Definitely works with Windows 10! Please contact support@runicgames.com so that we can troubleshoot this issue.

    Thanks!
    BrianW
    Community Manager // Mr. Nice Guy

    Join us on Discord! https://discord.gg/runicgames

    For technical support, send a PM or contact us. You can check our knowledgebase for solutions to common issues.

    N9PPYBB.png
    Hob – coming soon to PC and PS4.
  • Hey there,

    I'm having the exact same issue and have tried everything I could think of, including all of the stuff that the author of this thread did. I even tried switching to OpenGL, which gets me a bit further (judging by the Ogre.log), but I'm guessing OpenGL isn't really supported for TL2. So I'm positive it's some type of DirectX issue. I tried reinstalling that a bunch of times also, but it didn't help. Has this been resolved?

    Thanks a lot.
  • I'm having this issue as well, exactly the same as OP. Game working on another machine with Windows 10, but not this one.
    Edit:
    Figured it out for myself after testing the GOG version and having it work until replacing the Steam files with it. Turns out Steam was running in Windows 8 compatibility mode (which I never set) and it works fine after disabling that.
Sign In or Register to comment.