Fixing the Strict NAT Issue In Multiplayer

gytfunkegytfunke Posts: 571
edited November 2016 in Torchlight II Support
So, here's how I fixed my strict NAT issue and some background info provided by Chthon.

Network Address Translation (NAT) is a method that enables Peer to Peer (P2P) connections like the one used for TL2. Your router has different NAT settings and these can affect your ability to play P2P games. Your NAT can be Strict, Medium, or Open. An unlimited number of people with Medium and Open NATs can play together. But, the problem comes with someone with a Strict NAT. If you have a Strict NAT you can only play with other players who have Open NATs. If anyone else has Strict or Medium NAT settings, you will suffer the well-known disconnects common to TL2's multiplayer.

So, here's how I fixed my NAT.

1) Enable Port Forwarding on your Router.

To do this:
-open the Command Line (CMD).
-type 'IPConfig', hit ENTER
-find the IPv4 address and the Default Gateway. Both of these are IP addresses. Here's an example of what that looks like (
-keep the CMD window open, you'll need to reference these IP addresses

-open your internet browser
-input the Default Gateway address into your html bar and hit ENTER, this should take you to your router login. If it doesn't, try
-enter your ID and password. Usually it's 'admin/password' by default.
-find the Port Forwarding settings for your router
-set Port Forwarding to enabled and enable forwarding to the following TCP and UDP ports:

2) Edit your local_settings.txt file

Runic suggests this might help your NAT and this is what worked for me. ... t-detected

-go to your Torchlight 2 folder, usually USER/DOCUMENTS/MY GAMES/RUNIC GAMES/TORCHLIGHT 2/
-open local_settings.txt
-change the line UDPORT :0 to a port number within the ranged we opened for Port Forwarding on our router. For example, I set mine to UDPORT: 4172. I don't know for sure, but I suspect it's best not to set it to the same port that TL2 already requires. You can see which ports those are here: ... quirements

If someone knows more about this problem, please feel free to pitch in. If this works for you, let me know here. If it doesn't, let me know, too.


  • D2HansD2Hans Posts: 3,031 ✭✭✭
    Thanks for posting this.

    Some of the people with Strict NAT might not be able to fix it if the issue is with the ISP. Quite a few ISP's have been implementing NATS since they have been running out of IP's quite often these people will be getting an address which is one of those local network addresses usually it will be the 10.x.x.x range since they usually have less issues when dealing with their modem/wireless router or if the customer has their own modem/router.

    Still the steps you outlined will make it easier to play multiplayer.
    "Six... one, six... the nuuuumber ooof the beeeaaast!"
  • Despite the fact that most users nowadays use this particular IP as a default IP, there are many additional wireless router brands who use other IP addresses..

    The pc connected to the system will completely on its own get a special IP address if the wireless router has built in DHCP functions. Just make sure the default wireless router IP address and the Default gateway are definitely the very same.

    Often, the default gateway is going to be, just like the wireless router IP address. You can find all information on this website
  • PhanjamPhanjam Posts: 3,297 ✭✭✭
    Thx v much Mike!
    Torchlight 1 Class Pack (TL1CP) Mod for TL2: Steam | RGF
  • ZiddersZidders Posts: 14,348 ✭✭✭
    This should be stickied imo.
Sign In or Register to comment.