Console key not working

Hal9000xHal9000x Posts: 47
edited December 2016 in TL2 General Discussions
Hey guys,

I enabled the console via both the keybinds.dat and settings.txt just for good measure. This is a mod save fyi. I also checked the keybinds.dat to make sure that the console is bound to Insert and has no modifier key (45 and -1 respectively). Also doubled checked my keybinds in game, nothing bound to Insert. Still cannot bring it up though. Was the console patched out, or perhaps doesn't work on modded saves?

Comments

  • DarkTailsDarkTails Posts: 4,148
    It works on modded saves because I use it to spawn custom weapons from people's mods.

    Only thing I can think of is close the game before editing and saving the text files or else the game won't use the updated files.
  • DarkTails wrote:
    It works on modded saves because I use it to spawn custom weapons from people's mods.

    Only thing I can think of is close the game before editing and saving the text files or else the game won't use the updated files.

    Did that, ofc. Double checked my changes several times after closing and restarting. This is very frustrating. I have done everything.
  • DarkTailsDarkTails Posts: 4,148
    I enabled the console just now to see if there would be any problems, but everything went fine. All I did was edit the settings.txt

    Using Windows 7 Home, dont know if there can be problems with Windows 10, etc.

    Try contacting Runic's support, or asking one of the yellow text names
  • RnFRnF Posts: 1,000
    Hal9000x wrote:
    Hey guys,

    I enabled the console via both the keybinds.dat and settings.txt just for good measure. This is a mod save fyi. I also checked the keybinds.dat to make sure that the console is bound to Insert and has no modifier key (45 and -1 respectively). Also doubled checked my keybinds in game, nothing bound to Insert. Still cannot bring it up though. Was the console patched out, or perhaps doesn't work on modded saves?

    The console only works in Single Player games, make sure you are not in a Multiplayer game or a LAN game.
  • Using Windows 7 Ultimate in Single Player mode.
  • D2HansD2Hans Posts: 3,029 ✭✭✭
    Maybe check the regional settings for the keyboard. I know I quite often have to do since I live in **** and the OS always thinks I have a French Canadian keyboard. Some times the OS just likes adding it back in. I usually have to check to make sure that I have the US keyboard selected and is the only keyboard installed, if it is not than I have issues.
    "Six... one, six... the nuuuumber ooof the beeeaaast!"
  • D2Hans wrote:
    Maybe check the regional settings for the keyboard. I know I quite often have to do since I live in **** and the OS always thinks I have a French Canadian keyboard. Some times the OS just likes adding it back in. I usually have to check to make sure that I have the US keyboard selected and is the only keyboard installed, if it is not than I have issues.


    Thanks, appreciate it. It's US though. I'm an IT guy by trade so I check the usual stuff. This one has me mystified.
  • D2HansD2Hans Posts: 3,029 ✭✭✭
    Which version of the game is it. If it is steam maybe the steam overlay is blocking it.

    I never tried to see if you can change the key to some other key.
    "Six... one, six... the nuuuumber ooof the beeeaaast!"
  • D2Hans wrote:
    Which version of the game is it. If it is steam maybe the steam overlay is blocking it.

    I never tried to see if you can change the key to some other key.

    Already disabled all Steam interactions including overlay, cloud saves etc. :(

    I have given up on this one.
  • DarkTailsDarkTails Posts: 4,148
    D2Hans wrote:
    Which version of the game is it. If it is steam maybe the steam overlay is blocking it.

    I never tried to see if you can change the key to some other key.

    I'm using the Steam version, it worked fine when I activated it. (Documents > Runic Games > Torchlight 2 > saves >numbers folder > settings)

    It affects normal saves and mod saves.

    Maybe reinstall?
  • ZiddersZidders Posts: 14,340 ✭✭✭
    Right click on the game in Steam and go to properties. From there go to files and verify the integrity of the file cache. Also in launch options make sure -console is there. I don't see anything in this thread mentioning it so not having it enabled via launch options might be the issue.
    ItfooQF.png
  • NighyiunNighyiun Posts: 3

    If possible, we would like more information on this issue.

Sign In or Register to comment.