no objective

I finished the water part and collected the two things from inside the two giant robots. But now there is no quest marker anymore. So I don`t know where you can use those two things or if I have to collect more.

Tagged:

Answers

  • okidnaokidna Posts: 2
    edited October 1

    Same thing happened to me under similar condition : after retrieving Great Core from the Water and Desert region, the objective/quest marker vanished. I ended up running around checking every possible new path and opened/raised some land but still no objective marker or no idea what to do.

    EDIT : I found the way to remove another corruption (a top of the pile of dead robots), maybe the objective marker will appear again if all the corruptions are removed.

  • okidnaokidna Posts: 2

    Yup, confirmed it, you need to clear all of the corruptions so the objective marker will appear again.

    What a great game, thanks Runic!

  • How_LemonHow_Lemon Posts: 2

    I did remove all the corruption, but the objective is still not showing, and the corruption area in the desert is still showing on the map :(

  • weltasweltas Posts: 3

    Same problem here :neutral:

  • weltasweltas Posts: 3

    Yes. I also did remove corruption dead robots, but still no quest marker :(

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file