Crash on Start Up - Fatal Initialization Failure

Good day,

I was gifted a copy of Torchlight 2 through Steam recently and when trying to run it, I get the following message "Fatal Initialization Failure".

I have tried both uninstalling TL2 and deleting the TL2 folder from my Steamapps folder but neither worked to resolve the issue. In addition, I have tried launching the game from both the modded and vanilla exe's from within the TL2 folder but again met with negative results. In fact, launching directly from the exe causes an immediate Fatal Initialization Failure whereas launching from Steam at least brought up the launcher.

I have additionally tired:

Re-installing DX9,
Installing the game on my SSD (no Fatal Initialization Failure unless running directly from the exe in the TL2 folder but still crashes before the game loads)
Running in compatibility mode (all)
Repairing the C++ Runtimes,
Doing a complete graphics driver uninstall (using Display Driver Uninstall utility) and reinstall,
Rolling back drivers
Deleting the Runic games folder located in mydocuments/my games,
Verifying the cache through Steam,
Varying the launch options (-novid, -autoconfig, -safe)

Searching the web for similar issues returned a smattering of results, mostly from around 2010-2012 and none with a resolution. I've submitted a ticket but it's unclear if I'll receive any help.

As this was a gift my daughter who was really looking forward to playing with me I'd hate to have to refund it. If anyone has some ideas on how I can resolve this issue I'd be eternally grateful!



  • KamikameKamikame Posts: 1

    Hello Arcanumus.

    I have the same problem!
    Have bought an extra copy of TL2, so I can play with my son.
    But I have the same message "Fatal Initialization Failure"
    SomePlease help! : - )

  • ArcanumusArcanumus Posts: 2

    Sorry to hear that, Kamikame. :/ However, perhaps if we compare some system specs and other configuration details we'll be able to determine what's causing us to get this error.

    I have friends who run TL2 trouble free with almost the same hardware as myself so there must be something pretty specific with our systems that are causing us to experience this where almost no one else does.

    To begin, I've attached a DxDiag report here and suggest you do the same. If you're unsure how to generate one, here's a link on how to:

    Here's hoping we can track this down, fix the problem and be playing with our respective kids asap!

Sign In or Register to comment.