[Workaround] Stuck Characters

Community support forum for the Torchlight single-player game.

[Workaround] Stuck Characters

Postby travisbaldree » Tue Oct 27, 2009 3:57 pm

If you are stuck! There is a solution-

If you have a town portal, try opening it and going through if you can -
However, if that doesn't work, I have a handy console command we can enable for you. You can 'ascend' a floor ( which will NOT mark you as a cheater ), and that should get you out.

From start->run

%appdata%

and press enter

Then browse to runic games\torchlight
there should be a settings.txt file in there

change
Console :0

to

Console :1

Now, when you load your character, hold SHIFT and press the ~ key
a console should come up -
type ASCEND and press return
that should pop you up a level and hopefully you should be un-stuck.

EDIT: If you're on a Mac:

1) Browse to ~/Library/Application Support/runic games/torchlight (replace ~ with your username)
2) Open settings.txt
3) Change Console :0 to Console :1 and save
4) Launch Torchlight
5) While loading your character, hit shift+~
6) A console should appear. Type ASCEND and press return. This should resolve the issue.

Note: On either Mac and PC you may inadvertently enter a testing level if you hold down shift alone while loading your character. Other posters have mentioned receiving a green screen. This is most likely the cause. A simple shift+~ key command for a moment is all that is required to trigger the console.
Last edited by BrianW on Wed Oct 10, 2012 3:05 pm, edited 2 times in total.
Reason: adjusted title to make it clearer and more consistent to the user
User avatar
travisbaldree
Runic Staff
 
Posts: 1610
Joined: Fri Jun 05, 2009 4:17 pm

Re: Stuck?

Postby veganwa » Tue Oct 27, 2009 5:03 pm

Man, I wish I had read this five minutes ago :P I was in a Secret Mine, wreaking my usual havoc, when all of a sudden I found myself transported up to a ledge (where a few enemies had spawned and jumped down moments before) with no chance of getting down. In this case the bug was actually welcome, as it gave me a good excuse to stop playing for the night, but it's still good to see that there is a workaround for getting stuck in the geometry should it happen again. But I guess the console has to be enabled upon game start for it to work, right?

But I have a question regarding the ASCEND-command: what happens if I use it in a Secret Mine, or another area outside of the main dungeon? Will it simply transport me to the level from which I teleported into the area?

Lastly, some information regarding the bug, should it be of interest: I suspect it might have happened when I unsuspectedly clicked on a weapon that had dropped up on the aforementioned ledge. In a way that could probably be the real bug, as I assume items dropping out of reach isn't really according to plan anyway? :)
Torchlight version: Steam
System: Intel Q9450, 4 GB RAM, Geforce 8800 GTX, NI Audio Kontrol 1, Windows XP SP3 w/all updates
veganwa
 
Posts: 1
Joined: Tue Oct 27, 2009 4:29 pm

Re: Stuck?

Postby xtarsia » Tue Oct 27, 2009 7:43 pm

im stuck, cant use a town portal scroll, and the console will not work even following ur instructions.

first, settings.txt gets reset every time i open the game.
second, setting it to read only still results in me not being able to bring up the console.
third, i presumed this was due to american vs british keyboard layouts and the tilide key, on a british keyboard tilide is shift+# (i tried shift+¬ aswell)
so,
fourth, i changed

KEYMAP_CONSOLEKEY_PRESS :192 (~)

to

KEYMAP_CONSOLEKEY_PRESS :76 (L)

this change should mean i now have to press shift+L to get the console up.

Still no console.

still stuck.

to note, vista 64 + steam

http://i37.tinypic.com/e99kwh.jpg
Help please!
xtarsia
 
Posts: 4
Joined: Tue Oct 27, 2009 7:05 pm

Re: Stuck?

Postby Zekran » Tue Oct 27, 2009 8:16 pm

In my case, the settings.txt saves but pressing Shift+~ does not bring up anything resembling a console.

Vista Business
Steam


I was having fun with that destroyer too.
Zekran
 
Posts: 2
Joined: Tue Oct 27, 2009 8:14 pm

Re: Stuck?

Postby xtarsia » Tue Oct 27, 2009 8:26 pm

some more stuff of interest:

deleting the settings file and then running the game results in the game creating a new settings file with all default values. (ie back to square one)

i then noted that leaving it writable, and proceeding to edit ANYTHING the values stick when running the game.

however the 2nd i change CONSOLE :0 to 1

and then run the game, that value gets changed back.

nothing else gets reset though.

Why?

also http://www.xtarsia.net/torchlight/0.svt if someone would kindly, load that save game, teleport me up 1 level and upload the "fixed" save somewhere?

Preferably would like to be able to get the console working though incase this happens again :(
xtarsia
 
Posts: 4
Joined: Tue Oct 27, 2009 7:05 pm

Re: Stuck?

Postby Zekran » Tue Oct 27, 2009 8:40 pm

Same for me now that I dig into the settings.txt more. No other values will revert except the Console command.


Running the game reverts it back to 0.
Zekran
 
Posts: 2
Joined: Tue Oct 27, 2009 8:14 pm

Re: Stuck?

Postby Badmagic » Tue Oct 27, 2009 9:00 pm

Same as all else, played the demo, was pleasantly surprised, purchased the game and got wellied in, an hour or so later approx got stuck.

I can always restart as its only one or two hours on this character but this could just as easily turn into twenty hours in on the next one, as such I would rather get this resolved first.

Changed "Console :0" to read "Console :1", made the file "Read Only" after seeing it refused to stay set on the first attempt.

SHIFT+~
SHIFT+¬
SHIFT+`
SHIFT+#

And dozens of other random combination's which get further and further from the posted keys seem to have zero effect.

Its been a very long time sine I have had to manually bind anything so I have no idea what the numbers represent anymore, only thing I can presume is 192=Tilde and 16=Shift (purely speculative from what's been stated combined with whats within the .txt file).

Anyway............ :|

***EDIT***

Sorry, neglected to say but...

O/S: W7-64u

Region and Language:

Format: English (UK)
Location: UK
Keyboards and Languages: English (UK)

*END*EDIT*
User avatar
Badmagic
 
Posts: 10
Joined: Tue Oct 27, 2009 8:42 pm

Re: Stuck?

Postby Volbard » Tue Oct 27, 2009 9:15 pm

I've saved a version of your character with him in town, hope that helps:

http://flamingbarrels.com/Ascended.svt

Sorry the console isn't working, it may have something to do with the way it was disabled for the demo. Hopefully we can get that fixed up soon as well.
User avatar
Volbard
Runic Staff
 
Posts: 415
Joined: Fri Jun 05, 2009 3:41 pm

Re: Stuck?

Postby xtarsia » Tue Oct 27, 2009 9:17 pm

ooh, thank you very much!

or actually... curse you! i was just about to go to sleep :lol:
xtarsia
 
Posts: 4
Joined: Tue Oct 27, 2009 7:05 pm

Re: Stuck?

Postby kybarsfang » Wed Oct 28, 2009 2:17 am

Travis' instructions worked for me. Thanks!
"Modder" =/= "Cheater"
"Modder" > "Cheater"

The difference between constructive criticism and whining is the ability to provide a realistic solution.

Felicia Day plays Torchlight!
User avatar
kybarsfang
 
Posts: 97
Joined: Tue Oct 27, 2009 1:00 pm

Re: Stuck?

Postby Connway » Wed Oct 28, 2009 2:49 am

I tried everything described and I couldn't get the console window open. Is there a possibility of getting a /stuck style command or something into a patch? So that players don't have to access the console and run through an entire floor?
Connway
 
Posts: 2
Joined: Wed Oct 28, 2009 2:41 am

Re: Stuck?

Postby Geldor » Wed Oct 28, 2009 3:46 am

To me it was Shift + Ø (Norwegian keyboard).
Geldor
 
Posts: 18
Joined: Sun Jun 07, 2009 10:43 pm

Re: Stuck?

Postby mondsohn » Wed Oct 28, 2009 3:48 am

Hi, Im stuck too, between a table and two boxes. I cant open the console in the described way, is there anything i can do but start from the beginning?
mondsohn
 
Posts: 1
Joined: Wed Oct 28, 2009 2:29 am

Re: Stuck?

Postby cordsie » Wed Oct 28, 2009 11:42 am

Stuck as well. Console setting gets reverted back to 0 when I run the game, and there's no way to get any console up.

Basically game over.
cordsie
 
Posts: 1
Joined: Wed Oct 28, 2009 11:41 am

Re: Stuck?

Postby Gene » Wed Oct 28, 2009 11:52 am

Here's a direct link to an image showing a location where you can get stuck; it's duplicatable at this location (just kinda mill about in the 'V' location where the boxes and table meet).

Here's the link:
http://img503.imageshack.us/img503/8851/stickpoint.jpg
User avatar
Gene
 
Posts: 90
Joined: Tue Jun 16, 2009 5:01 pm
Location: New Carlisle, IN

Re: Stuck?

Postby SnarkFish » Wed Oct 28, 2009 3:54 pm

stuck here also. hit a trap that pushed me over a set of rocks and cannot move, cannot use town portal and cannot access console

http://imgur.com/nAL6k.jpg
SnarkFish
 
Posts: 8
Joined: Wed Oct 28, 2009 3:45 pm

Re: Stuck?

Postby apollo » Wed Oct 28, 2009 4:15 pm

I am also stuck. Tried the console fix with no luck. Can't use a town portal. Any help would be appreciated.

http://dl.getdropbox.com/u/928377/photos/torchlight.jpg
apollo
 
Posts: 1
Joined: Wed Oct 28, 2009 4:04 pm

Re: Stuck?

Postby Masterson » Wed Oct 28, 2009 4:31 pm

I'm stuck as well. Only the third level in. Console doesn't work. This looks to be something you all at Runic might want to address rather quickly.
Masterson
 
Posts: 3
Joined: Wed Oct 28, 2009 4:27 pm

Re: Stuck?

Postby jamesL » Wed Oct 28, 2009 6:25 pm

anybody want to email me their char and I'll use the console to ascend them
then I can email the char file back to you
I don't have a sig
jamesL
 
Posts: 3360
Joined: Fri Jun 05, 2009 7:01 pm

Re: Stuck?

Postby iChi » Wed Oct 28, 2009 7:17 pm

thx alot!!! HUGE HELP!
Image
User avatar
iChi
 
Posts: 8
Joined: Tue Oct 27, 2009 1:05 pm

Next

Return to Torchlight Win/Mac/Linux Support

Who is online

Users browsing this forum: No registered users and 2 guests